Attention Internet Explorer hold-outs; you're about to get another firm push to upgrade to at least Internet Explorer 7, if not 8.

Google. has announced that starting in March it will no longer support IE 6. It is also phasing out support for any browser older than Chrome 4.0 or Firefox 3.0, as well as Safari 3.0.

What does this mean? Specifically, older browsers will no longer work with Google Docs & Spreadsheets.

This is signicant when you consider this:

- 63% of all computer users worldwide use Internet Explorer.

- Of that 63%, one in five are still using Internet Explorer 6.

Here's the link to download Internet Explorer 8, if this means you.